Error install Raudus 0.9.9 on Lazarus 1.4.2

Raudus Forums Installation Error install Raudus 0.9.9 on Lazarus 1.4.2

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  maxxir 6 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #852170

    n3mo
    Participant

    Hi Masters,   I am a Delphi developer for years but I’ve been away from development, however, i’m going to develop!… seeking alternatives to “migrate” my desktop app got raudus web applications, but also to Lazarus (I did not know).

    I tried to install raudus but I can not finish installing the package lazarus:

    – My development environment is on windows 7 64bit.

    – I installed Lazarus 1.4.2

    – I installed Raudus Raudus 0.9.9.

    – I ran welding.exe, which ended successfully.

    – I applied the patch to Lazarus in file sourcefilemanager.pas in procedure TryRegisteredClasses

    – I opened the “RaudusFPC.lpk” package from Lazarus

    – I started the compilation and this ended successfully.

    – Finally I started the installation, but this ends with errors do not know how to solve:Construir IDE:

    Código de salida 2, Errores: 4, Sugerencias: 1lazarus.pp(41,3) Hint: Unit “redirect_stderr” not used in Lazaruslazarus.pp(142,1) Error: Undefined symbol: PROJECTINTF_TPROJECTFILEDESCRIPTOR_$__SETOWNER$TOBJECTlazarus.pp(142,1) Error: Undefined symbol: CONTROLS_TWINCONTROL_$__GETCHILDSRECT$BOOLEAN$$RECTlazarus.pp(142,1) Error: Undefined symbol: CONTROLS_TCONTROL_$__GETCHILDSRECT$BOOLEAN$$RECTlazarus.pp(142,1) Error: Undefined symbol: GRAPHICS_TCUSTOMBITMAP_$__GETRESOURCETYPE$$PCHAR

    I find it very interesting and worthwhile project raudus as I would love to use it and spread it, but I worry about its continuity, because it cost me a lot to find information, including wiki’s official website is down.

    • This topic was modified 6 years, 3 months ago by  n3mo.
    #852374

    maxxir
    Participant

    For what install on Laz. 1.4.2 ? That’s wrong.

    Try developer recommended:

    lazarus-1.2.6-fpc-2.6.4-win32.exe

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.